[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[IMP-users] Wrong CMake warning when building IMP 2.2.1

Dear all,

I am building IMP by using a Boost installation in a non-standard location. When running cmake with "-DBOOST_ROOT=/my/boost/root", the configuration ends successfully but at the end a warning is issued:

CMake Warning: The variable, 'BOOST_ROOT', specified manually, was not used during the generation.

However I don't think this warning is true, because if I run cmake w/o "-DBOOST_ROOT=/my/boost/root", I run into a configuration error:

CMake Error at /g/software/linux/pack/cmake-2.8.4/share/cmake-2.8/Modules/FindBoost.cmake:1128 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.33.1

  Boost include path: /usr/include

  Detected version of Boost is too old.  Requested version was 1.38 (or

  The following Boost libraries could not be found:


No Boost libraries were found. You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of

etc. etc.

So in fact the variable BOOST_ROOT *is* used and the warning is wrong (or at least misleading).

This warning didn't appear when configuring IMP 2.2.0