[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[IMP-users] RMF error while building

Hi imp users, 

Yesterday I had 2 running imp's in 2 computers: 2.0.1 version and the developer version downloaded from github. I deleted both (imp folder and path lines from bash) to get the 2.1.1 version because I am still using IMP.restrainer and I need rmf module to make a movie. 

I get this error over and over again in both computers:

[ 88%] /home/bioinfo/Programs/imp/swig/IMP_rmf.impl.i:1: Error: Unable to find 'RMF.i'
Running swig on restrainer
Traceback (most recent call last):
  File "/home/bioinfo/Programs/imp-2.0.1/tools/build/make_swig_wrapper.py", line 97, in <module>
  File "/home/bioinfo/Programs/imp-2.0.1/tools/build/make_swig_wrapper.py", line 90, in main
    run_swig(outputdir, options)
  File "/home/bioinfo/Programs/imp-2.0.1/tools/build/make_swig_wrapper.py", line 47, in run_swig
    % (ret, " ".join(args)))
OSError: subprocess failed with return code 1: swig -castmode -interface _IMP_rmf -DPySwigIterator=IMP_RMF_PySwigIterator -DSwigPyIterator=IMP_RMF_SwigPyIterator -python -c++ -naturalvar -fvirtual -Wextra -I../../include -I../../swig -oh wrap.h-in -o wrap.cpp-in -I/home/bioinfo/Programs/imp/include -I/usr/include /home/bioinfo/Programs/imp/swig/IMP_rmf.i
make[2]: *** [src/rmf_swig/wrap.cpp] Error 1
make[1]: *** [modules/rmf/pyext/CMakeFiles/_IMP_rmf.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX shared library ../../../lib/libimp_domino.so
Scanning dependencies of target _IMP_restrainer
[ 88%] Built target imp_domino
[ 89%] Building CXX object modules/restrainer/pyext/CMakeFiles/_IMP_restrainer.dir/__/__/__/src/restrainer_swig/wrap.cpp.o
Linking CXX shared module ../../../lib/_IMP_restrainer.so
[ 89%] Built target _IMP_restrainer
^Cmake[2]: *** [modules/core/pyext/CMakeFiles/_IMP_core.dir/__/__/__/src/core_swig/wrap.cpp.o] Interrupt
make[1]: *** [modules/core/pyext/CMakeFiles/_IMP_core.dir/all] Interrupt
make[2]: *** [modules/atom/pyext/CMakeFiles/_IMP_atom.dir/__/__/__/src/atom_swig/wrap.cpp.o] Interrupt
make[1]: *** [modules/atom/pyext/CMakeFiles/_IMP_atom.dir/all] Interrupt

I searched for the RMF.i file it is ok located in rmf/dependency/RMF/swig/RMF.i

I tried with all versions (even getting the RMF_source from git to get the module), I tried to turn off the network as Jan suggested here ,I tried the developer version also, installed the doxygen 1.8.5 version also and the same error always. I don't know what I am missing because yesterday I installed the 2.1.1 and the developer version in one of the computers without problems, and today does not work. 

I would really appreciate your help, 

thanks a lot

Ibai Irastorza Azkarate, PhD Student
Centro Andaluz de Biología del Desarrollo CABD
Universidad Pablo de Olavide,
Carretera de Utrera km1,
41013 Sevilla, Spain