[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [IMP-users] Failed to build IMP

Yeah, the directions are slightly different (as you saw) between the release and develop. Not sure how best to make that clear. I'll see if I can make it give a clearer warning if the RMF_source dir is empty.

On Jul 9, 2013, at 12:22 AM, Dan Cohen <">> wrote:

Thank you! This was indeed the problem, now IMP has been fully built.

I was using this :


Which does not mention this step.

Thank you again,

On 9 July 2013 02:02, Daniel Russel <" target="_blank">> wrote:
It sounds a lot like you didn't do "./setup_git.py" or another command to pull in the RMF submodule. What directions were you following? They might need to be updated.

Hello all,

I tried to build IMP on an ubuntu 12.04 by going over the directions in your site.
These are the directions I used :

Building IMP from source is straightforward if the prerequisites are already installed. We recommend you get IMP from git by git clone git://github.com/salilab/imp.git To build, create a directory to build IMP in (it is good practice not to build in the source directory and do)

cmake ../imp -DCMAKE_BUILD_TYPE=Release
make -j 4
The only change I did was to disable Doxygen.
I did the git clone about 12 hours ago.

The build runs OK until it fails on one of the swig creation phases :

[ 70%] Built target _IMP_symmetry
[ 70%] Built target imp_symmetry_python
[ 71%] Built target _IMP_atom
[ 72%] Built target imp_atom_python
[ 72%] Built target _IMP_scratch
[ 73%] Built target imp_scratch_python
[ 73%] Built target _IMP_em
[ 73%] Built target imp_em_python
[ 73%] Built target _IMP_kinematics
[ 74%] Built target imp_kinematics_python
[ 75%] Built target _IMP_misc
[ 75%] Built target imp_misc_python
[ 75%] Running swig on rmf
Traceback (most recent call last):
  File "/home/bojemoi/university/imp-source/tools/build/make_swig_wrapper.py", line 94, in <module>
  File "/home/bojemoi/university/imp-source/tools/build/make_swig_wrapper.py", line 87, in main
    run_swig(outputdir, options)
  File "/home/bojemoi/university/imp-source/tools/build/make_swig_wrapper.py", line 44, in run_swig
    ret = tools.run_subprocess(args, cwd=outputdir)
  File "/home/bojemoi/university/imp-source/tools/build/tools.py", line 465, in run_subprocess
    % (ret, " ".join(command)))
OSError: subprocess failed with return code 1: swig -castmode -interface _IMP_rmf -DPySwigIterator=IMP_RMF_PySwigIterator -DSwigPyIterator=IMP_RMF_SwigPyIterator -python -c++ -naturalvar -fvirtual -Wextra -I../../include -I../../swig -oh wrap.h-in -o wrap.cpp-in -I/home/bojemoi/university/imp-release/include -I/usr/include /home/bojemoi/university/imp-release/swig/IMP_rmf.i
make[2]: *** [src/rmf_swig/wrap.cpp] Error 1
make[1]: *** [modules/rmf/pyext/CMakeFiles/_IMP_rmf.dir/all] Error 2
make: *** [all] Error 2

When trying to execute the same command myself (the swig command that fails with error code 1) I get :

bojemoi@linux:~/university/imp-release$ swig -castmode -interface _IMP_rmf -DPySwigIterator=IMP_RMF_PySwigIterator -DSwigPyIterator=IMP_RMF_SwigPyIterator -python -c++ -naturalvar -fvirtual -Wextra -I../../include -I../../swig -oh wrap.h-in -o wrap.cpp-in -I/home/bojemoi/university/imp-release/include -I/usr/include /home/bojemoi/university/imp-release/swig/IMP_rmf.i

/home/bojemoi/university/imp-release/swig/IMP_rmf.impl.i:1: Error: Unable to find 'RMF.i'

Many other modules that do not relate to RMF.i build correctly and I can import them from python , but I happen to need multfit that DOES require RMF...

I tried to search for RMF.i in my release directory :

bojemoi@linux:~/university/imp-release$ find | grep RMF

bojemoi@linux:~/university/imp-release$ cat data/build_info/RMF

Swig version is 2.0.4 by the way.

Thank you!
IMP-users mailing list
" target="_blank">

IMP-users mailing list

IMP-users mailing list