then maybe I should update that for Vector3D and Rotation3D as well,
as it was not possible accessing Transformation3D which was
constructed from the default one before.
I don't understand that sentence. But, if you are saying that
Vector3D() should be Vector3D(0,0,0) I disagree and prefer it to be
left undefined (or in a defined, but non-useful state). And thing
Transformation3D should be changed to match.