[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [IMP-dev] minor quibble

Daniel Russel wrote:
It probably better to call it UnaryFunction rather than UnaryFunctor as unary functors already mean something more general in C++ (any functor that takes one variable). I guess strictly speaking it should be UnaryRealFunction, but we can get elide the Real.

Fair enough; as of r319 they are UnaryFunctions.

"It is a capital mistake to theorize before one has data."
	- Sir Arthur Conan Doyle