No one seems to ever use the name on Restraints as opposed to restraint
sets. I propose we get rid of the name field to make restraint lighter.
Agreed.
I also propose we get rid of the active flag as it is not really used
and can also be pushed into a restraint set if the functionality is
desired.
It's not really used because we don't have any tests or applications for
turning particles on and off yet, and it's my recollection that
restraints would become deactivated if they acted on turned-off
particles. Certainly in the Modeller world any single restraint can be
turned on or off during the course of an optimization, so that would
require putting every single restraint into its own restraint set. So I
think we should keep the active flag for now. It's only one bool. ;)