[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [IMP-dev] Proposed change to checks and asserts



On Oct 9, 2009, at 4:20 PM, Ben Webb wrote:

On 10/09/2009 03:58 PM, Daniel Russel wrote:
To address this, I propose:
- provide IMP_implementation_check and IMP_usage_check macros
- provide a methods to turn on and off the two different types of checks
independently
- remove the concept of check levels
Sounds reasonable to me. The only problem I have with it is that  
IMP_implementation_check is kind of long to type, and easy to  
misspell (as you in fact have already demonstrated later in your  
email!)
Agreed, anything shorter to suggest that gets the point across? Not that short would prevent me from misspelling it.
"internal" probably would do.