Daniel Russel wrote:
> The name ScoreState seems to confuse a few people. As Hao pointed out,
> they are actually constraints. Any reasons not to rename them to that?
I don't think constraint is a good word, since many people assume
"restraint" and "constraint" mean the same thing. And ScoreState need
not be a constraint - it's simply a class that gets updated every time
you score the model. For example, you could write a ScoreState that
simply counts how many times you score the model. It would be weird to
describe that kind of behavior as a "constraint".
Ben
--
ben@salilab.orghttp://salilab.org/~ben/
"It is a capital mistake to theorize before one has data."
- Sir Arthur Conan Doyle