Daniel Russel wrote:
We have been kind of inconsistent about molecularhierarchy-related helper methods, for example molecular_hierarchy_get_by_type. Some of the methods have a molecular_hierarchy_ prefix and some not. I propose (as was Ben's preference when this was discussed before) to remove the prefix from the methods which have it:molecular_hierarchy_get_by_type becomes get_by_type and molecular_hiearchy_get_residue becomes get_residue
I thought I actually proposed they were static methods. ;) But your proposal sounds fine to me.
Ben -- ben@salilab.org http://salilab.org/~ben/ "It is a capital mistake to theorize before one has data." - Sir Arthur Conan Doyle