Daniel Russel wrote:
> On Oct 8, 2008, at 9:59 AM, Ben Webb wrote:
>> Daniel Russel wrote:
>>> I would suggest having one header in each module called basic.h or
>>> base_types.h or something similar which does the job of base_types.h
>>> in IMP and defines the export and namespace macros.
>> 'base_types.h' seems a little odd since neither the export nor the
>> namespace macros are types. That header is actually doing the job of
>> IMP_config.h, so we could call it config.h, but I don't know if
>> that's a
>> huge improvement over the current name.
> The IMP_ in IMP_config.h always seemed redundant.
I agree - it was really only there because we were a bit sloppy about
include paths at the time. It shouldn't be necessary any more.
> Agreed. "config.h" sounds good as it is nice and general and can
> handle all basic setup stuff.
Very well - I will rename accordingly.
Ben
--
ben@salilab.orghttp://salilab.org/~ben/
"It is a capital mistake to theorize before one has data."
- Sir Arthur Conan Doyle