Daniel Russel wrote:
As any of you who looked at the syntax may have noticed, the current syntax is a bit evil
I did notice that.
One possibility is something like IMP_IF_CHECK(level) which would expand to if (get_check_level() > level)
Sounds good to me. Ben -- ben@salilab.org http://salilab.org/~ben/ "It is a capital mistake to theorize before one has data." - Sir Arthur Conan Doyle