In brief, NonbondedListScoreState is now an abstract class and the
corresponding class is AllNonbondedListScoreScoreState. I don't like the
name, so if you have a better one, please suggest it. I needed to have a
base class for the lists so that I can implemented one which handles
particles with varying radii nicely.
I guess one of us screwed something up with this refactoring, because
the unit test for the bipartite nonbonded list fails now, at least on my
Mac.