[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IMP class and module naming scheme




I use CamelCase
We should probably have some consensus on function names and attribute names I would go with:

get/set ( Daniel's convention):
protected:
int x_;
public:
int x() const {return x;}
imp mostly uses get_x() sort of names so far (there are a couple of exceptions).

void set_x(int x) { x_=x;}

and thus all class attributes should be name_ as well ( just to stay consistent)

and for other functions I would use CamelCase as well
Currently all classes are CamelCase and all functions_use_underscores. I like having the distinction as C++ can be ambiguous about what is a function and what is an object (in fact, for certain syntax it is undefined whether you are talking about a class or a function).


5. using namespace

are we ok with using namespace std for the IMP classes ??
Within a method is fine. Polluting someone else's code or the imp namespace, not so much :-)